$$INTRODUCTION$$ - %%projecttitle%%

EchoLink Programmer's Reference

Introduction

The EchoLink program includes built-in support for controlling some of its functions from custom-developed external programs, such as scripts or Visual Basic programs. This support is provided in the form of a COM Automation interface.

This documentation set is a reference to the components, properties, methods, and events of EchoLink's COM interfaces.


%%projecttitle%%

EchoLink Programmer's Reference (ver 1.7)

Version | 1.7.0 (Typelib version)
Component filename | EchoLink.tlb
Component GUID | {4CF5B97B-A0F5-41F3-848C-6E25FAB62AD3}

Description

EchoLink Object Library ver 1.7

Object Model


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started

Installation

The COM Automation interface for EchoLink is installed automatically when version 1.7 (or above) of EchoLink is installed.

Component and Library Names

The root object is EchoLinkSession, which has a program ID (ProgID) of "EchoLink.EchoLinkSession".

If you are programming with Visual Basic, add a reference to "EchoLink Object Library ver 1.7" to your project.

Implementation

The EchoLinkSession component is implemented as an out-of-process COM server, hosted by the EchoLink program (EchoLink.exe) itself.

When your program instantiates EchoLinkSession, it will connect to the existing, running instance of EchoLink, if any. If EchoLink is not already running, instantiating EchoLinkSession will start it up automatically. It is not possible to create multiple, distinct instances of EchoLink; all references to EchoLinkSession will refer to the same running instance.

Notes

Please disable the Tip of the Day feature (in EchoLink) when using the Automation interface, as it may interfere with proper operation of the API after EchoLink starts.


%%localitemtitle%%

CallsignList Collection
Description

CallsignList Class

Members

Methods
Append Add an item to the list

Properties
_NewEnum | Read-only property | property _NewEnum
Count | Read-only property | Number of items in the list Returns a count of the number of collection members
Item | Read-write property | Retrieve the value of an item Returns the member of the collection identified by the Key parameter


%%localitemtitle%%

Append Method

Description

Add an item to the list

Return Type

None

Syntax

object.Append sItem

The Append Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CallsignList.
sItem | Required. A Variant value.


%%localitemtitle%%

_NewEnum Property (CallsignList)

Description

property _NewEnum

Property type

An Unknown object.

Syntax

object._NewEnum

The _NewEnum Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CallsignList.


%%localitemtitle%%

Count Property (CallsignList)

Description

Number of items in the list Returns a count of the number of collection members

Property type

A Long value.

Syntax

object.Count

The Count Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CallsignList.


%%localitemtitle%%

Item Property (CallsignList)

Description

Retrieve the value of an item Returns the member of the collection identified by the Key parameter

Property type

A Variant value.

Syntax

object.Item(n) [= value]

The Item Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CallsignList.
n | Required. A Long value.
value | A Variant value.


%%localitemtitle%%

CommandList Collection
Description

CommandList Class

Members

Properties
_NewEnum | Read-only property | property _NewEnum
Count | Read-only property | Number of items in the list Returns a count of the number of collection members
Item | Read-write property | Retrieve the value of an item Returns the member of the collection identified by the Key parameter


%%localitemtitle%%

_NewEnum Property (CommandList)

Description

property _NewEnum

Property type

An Unknown object.

Syntax

object._NewEnum

The _NewEnum Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CommandList.


%%localitemtitle%%

Count Property (CommandList)

Description

Number of items in the list Returns a count of the number of collection members

Property type

A Long value.

Syntax

object.Count

The Count Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CommandList.


%%localitemtitle%%

Item Property (CommandList)

Description

Retrieve the value of an item Returns the member of the collection identified by the Key parameter

Property type

A Variant value.

Syntax

object.Item(sKey) [= value]

The Item Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type CommandList.
sKey | Required. A String value.
value | A Variant value.


%%localitemtitle%%

EchoLinkSession Object
Description

EchoLinkSession Class

Object Model

Members

Methods
Connect | Connect to the specified callsign or node number. Runs asynchronously unless bWait is True.
ControlDTR | Assert or inhibit the DTR pin on the TX Control COM port.
ControlRTS | Assert or inhibit the RTS pin on the TX Control COM port.
Disconnect | Disconnect from the specified callsign.
DisconnectAll | Disconnect all stations.
EnableLink | Enable or disable the link.
IsPeerConnected | Return True if the specified station is connected.
PausePlayback | Pause or un-pause any playback in progress.
PlayWAVFile | Play the specified WAV file. Return after the file finishes playing if bSync is True, otherwise return immediately.
PTTControl | Key (or un-key) the local transmitter.
Quit | Shut down EchoLink.
RefreshStationList | Refresh the Station List.
Reset | Clear all connections and apply all configuration changes.
SendDTMFString | Send a string of DTMF digits to the local transmitter.
SendID | Send a station ID over the RF link.
SendToneBurst | Send a tone burst over the local transmitter.
Shutdown | Shut down the EchoLink application.
StartRecordingQSO | Begin recording the current QSO to the specified WAV file. A default filename is used if the filename argument is omitted.
StopPlayback | Stop any playback in progress.
StopRecording | Stop any recording in progress.
SwitchProfile | Reset the system and switch to a different profile.
Transmit | Begin (or end) transmitting to the connected station(s).

Properties
ListAsBusy | Read-write property | True if this node is listed as Busy, and not accepting connections.
NumPeers | Read-only property | The number of stations currently connected.
PTT | Read-only property | True if the local transmitter is currently keyed.
Receiving | Read-only property | True if audio is being received from a connected station.
RXSignal | Read-only property | True if the local transmitter is receiving a signal.
StationEntries | Read-only property | A collection of all items in the current Station List, which can be enumerated.
StationEntriesXML | Read-only property | An XML document enumerating all items in the current Station List.
SysopConfig | Read-only property | Retrieve the Sysop Configuration object.
SystemConfig | Read-only property | Retrieve the System Configuration object.
Transmitting | Read-only property | True if audio is being sent to connected station(s).

Events
Alarm | Notifies that an Alarm has been triggered.
CarrierDetect | Notifies that an RF signal has begun or ended.
ChatTextReceived | Notifies that a Text Message has been received in the Chat window.
Closing | Notifies that EchoLink is closing down, and all references are no longer valid.
Connected | Notifies that a station has connected.
Disconnected | Notifies that a station has disconnected.
DTMFString | Notifies that a string of DTMF digits has been received.
LinkStatusChange | Notifies that the link has been enabled or disabled.
PTT | Notifies that the RF transmitter has gone key-down or key-up.
RX | Notifies that an incoming Internet transmission has begun or ended.
SerialStatus | Notifies that a pin on the RX Control serial port has changed state.
StationListReceived | Notifies that the Station List has finished being retrieved.
StationTextReceived | Notifies that Station Text has been received in the Station Text window.
TX | Notifies that an outgoing Internet transmission has begun or ended.


%%localitemtitle%%

Connect Method

Description

Connect to the specified callsign or node number. Runs asynchronously unless bWait is True.

Return Type

None

Syntax

object.Connect sStation, bWait

The Connect Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
sStation | Required. A String value.
bWait | Required. A Boolean value.


%%localitemtitle%%

ControlDTR Method

Description

Assert or inhibit the DTR pin on the TX Control COM port.

Return Type

None

Syntax

object.ControlDTR bAssert

The ControlDTR Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bAssert | Required. A Boolean value.


%%localitemtitle%%

ControlRTS Method

Description

Assert or inhibit the RTS pin on the TX Control COM port.

Return Type

None

Syntax

object.ControlRTS bAssert

The ControlRTS Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bAssert | Required. A Boolean value.


%%localitemtitle%%

Disconnect Method

Description

Disconnect from the specified callsign.

Return Type

None

Syntax

object.Disconnect sStation

The Disconnect Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
sStation | Required. A String value.


%%localitemtitle%%

DisconnectAll Method

Description

Disconnect all stations.

Return Type

None

Syntax

object.DisconnectAll

The DisconnectAll Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

EnableLink Method

Description

Enable or disable the link.

Return Type

None

Syntax

object.EnableLink bEnable

The EnableLink Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bEnable | Required. A Boolean value.


%%localitemtitle%%

IsPeerConnected Method

Description

Return True if the specified station is connected.

Return Type

A Boolean value.

Syntax

object.IsPeerConnected (sStation)

The IsPeerConnected Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
sStation | Required. A String value.


%%localitemtitle%%

PausePlayback Method

Description

Pause or un-pause any playback in progress.

Return Type

None

Syntax

object.PausePlayback bPause

The PausePlayback Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bPause | Required. A Boolean value.


%%localitemtitle%%

PlayWAVFile Method

Description

Play the specified WAV file. Return after the file finishes playing if bSync is True, otherwise return immediately.

Return Type

None

Syntax

object.PlayWAVFile sFilename, bSync

The PlayWAVFile Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
sFilename | Required. A String value.
bSync | Required. A Boolean value.


%%localitemtitle%%

PTTControl Method

Description

Key (or un-key) the local transmitter.

Return Type

None

Syntax

object.PTTControl bPTT

The PTTControl Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bPTT | Required. A Boolean value.


%%localitemtitle%%

Quit Method

Description

Shut down EchoLink.

Return Type

None

Syntax

object.Quit

The Quit Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

RefreshStationList Method

Description

Refresh the Station List.

Return Type

None

Syntax

object.RefreshStationList bWait

The RefreshStationList Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bWait | Required. A Boolean value.


%%localitemtitle%%

Reset Method

Description

Clear all connections and apply all configuration changes.

Return Type

None

Syntax

object.Reset

The Reset Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

SendDTMFString Method

Description

Send a string of DTMF digits to the local transmitter.

Return Type

None

Syntax

object.SendDTMFString sDigits

The SendDTMFString Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
sDigits | Required. A String value.


%%localitemtitle%%

SendID Method

Description

Send a station ID over the RF link.

Return Type

None

Syntax

object.SendID eType, [vID]

The SendID Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
eType | Required. An elIDType enumeration, as described in settings.
vID | Optional. A Variant value.

Settings

The settings for eType are:

Constant | Value | Description
idDefault | 0
idMorse | 1
idSpoken | 2
idWave | 3


%%localitemtitle%%

SendToneBurst Method

Description

Send a tone burst over the local transmitter.

Return Type

None

Syntax

object.SendToneBurst nFrequency, nDuration

The SendToneBurst Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
nFrequency | Required. An Integer value.
nDuration | Required. An Integer value.


%%localitemtitle%%

Shutdown Method

Description

Shut down the EchoLink application.

Return Type

None

Syntax

object.Shutdown

The Shutdown Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

StartRecordingQSO Method

Description

Begin recording the current QSO to the specified WAV file. A default filename is used if the filename argument is omitted.

Return Type

None

Syntax

object.StartRecordingQSO [vFilename]

The StartRecordingQSO Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
vFilename | Optional. A Variant value.


%%localitemtitle%%

StopPlayback Method

Description

Stop any playback in progress.

Return Type

None

Syntax

object.StopPlayback

The StopPlayback Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

StopRecording Method

Description

Stop any recording in progress.

Return Type

None

Syntax

object.StopRecording

The StopRecording Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

SwitchProfile Method

Description

Reset the system and switch to a different profile.

Return Type

None

Syntax

object.SwitchProfile sNewProfile

The SwitchProfile Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
sNewProfile | Required. A String value.


%%localitemtitle%%

Transmit Method

Description

Begin (or end) transmitting to the connected station(s).

Return Type

None

Syntax

object.Transmit bTX

The Transmit Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
bTX | Required. A Boolean value.


%%localitemtitle%%

ListAsBusy Property

Description

True if this node is listed as Busy, and not accepting connections.

Property type

A Boolean value.

Syntax

object.ListAsBusy [= value]

The ListAsBusy Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.
value | A Boolean value.


%%localitemtitle%%

NumPeers Property

Description

The number of stations currently connected.

Property type

A Long value.

Syntax

object.NumPeers

The NumPeers Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

PTT Property

Description

True if the local transmitter is currently keyed.

Property type

A Boolean value.

Syntax

object.PTT

The PTT Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

Receiving Property

Description

True if audio is being received from a connected station.

Property type

A Boolean value.

Syntax

object.Receiving

The Receiving Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

RXSignal Property

Description

True if the local transmitter is receiving a signal.

Property type

A Boolean value.

Syntax

object.RXSignal

The RXSignal Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

StationEntries Property

Description

A collection of all items in the current Station List, which can be enumerated.

Property type

An Object object.

Syntax

object.StationEntries

The StationEntries Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

StationEntriesXML Property

Description

An XML document enumerating all items in the current Station List.

Property type

A String value.

Syntax

object.StationEntriesXML

The StationEntriesXML Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

SysopConfig Property

Description

Retrieve the Sysop Configuration object.

Property type

A SysopConfig object.

Syntax

object.SysopConfig

The SysopConfig Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

SystemConfig Property

Description

Retrieve the System Configuration object.

Property type

A SetupConfig object.

Syntax

object.SystemConfig

The SystemConfig Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

Transmitting Property

Description

True if audio is being sent to connected station(s).

Property type

A Boolean value.

Syntax

object.Transmitting

The Transmitting Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type EchoLinkSession.


%%localitemtitle%%

Alarm Event

Description

Notifies that an Alarm has been triggered.

Syntax

Private Sub object_Alarm(sStation, nStatus)

The Alarm Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
sStation | A String value.
nStatus | An Integer value.


%%localitemtitle%%

CarrierDetect Event

Description

Notifies that an RF signal has begun or ended.

Syntax

Private Sub object_CarrierDetect(bCD)

The CarrierDetect Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
bCD | A Boolean value.


%%localitemtitle%%

ChatTextReceived Event

Description

Notifies that a Text Message has been received in the Chat window.

Syntax

Private Sub object_ChatTextReceived(sText)

The ChatTextReceived Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
sText | A String value.


%%localitemtitle%%

Closing Event

Description

Notifies that EchoLink is closing down, and all references are no longer valid.

Syntax

Private Sub object_Closing()

The Closing Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.


%%localitemtitle%%

Connected Event

Description

Notifies that a station has connected.

Syntax

Private Sub object_Connected(sCall, sName, sAddr)

The Connected Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
sCall | A String value.
sName | A String value.
sAddr | A String value.


%%localitemtitle%%

Disconnected Event

Description

Notifies that a station has disconnected.

Syntax

Private Sub object_Disconnected(sCall)

The Disconnected Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
sCall | A String value.


%%localitemtitle%%

DTMFString Event

Description

Notifies that a string of DTMF digits has been received.

Syntax

Private Sub object_DTMFString(sDigits)

The DTMFString Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
sDigits | A String value.


%%localitemtitle%%

LinkStatusChange Event

Description

Notifies that the link has been enabled or disabled.

Syntax

Private Sub object_LinkStatusChange(bEnabled)

The LinkStatusChange Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
bEnabled | A Boolean value.


%%localitemtitle%%

PTT Event

Description

Notifies that the RF transmitter has gone key-down or key-up.

Syntax

Private Sub object_PTT(bPTT)

The PTT Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
bPTT | A Boolean value.


%%localitemtitle%%

RX Event

Description

Notifies that an incoming Internet transmission has begun or ended.

Syntax

Private Sub object_RX(bRX)

The RX Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
bRX | A Boolean value.


%%localitemtitle%%

SerialStatus Event

Description

Notifies that a pin on the RX Control serial port has changed state.

Syntax

Private Sub object_SerialStatus(nEvent, nStatus)

The SerialStatus Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
nEvent A Long value.

Contains any combination of one or more of the following bit values:

&h0008 (EV_CTS): The CTS (clear-to-send) signal changed state.

&h0010 (EV_DSR): The DSR (data-set-ready) signal changed state.

&h0020 (EV_RLSD): The RLSD (receive-line-signal-detect, also known as CD or carrier-detect) signal changed state.

nStatus A Long value.

Indicates the current status of the RS-232 signals, with a bit 1 indicating on (or asserted), and bit 0 indicating off (or inhibited).

The bit fields are defined as follows:

Value | Meaning
&h0010 | The CTS (clear-to-send) signal is on.
&h0020 | The DSR (data-set-ready) signal is on.
&h0080 | The RLSD (receive-line-signal-detect) signal is on.


%%localitemtitle%%

StationListReceived Event

Description

Notifies that the Station List has finished being retrieved.

Syntax

Private Sub object_StationListReceived()

The StationListReceived Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.


%%localitemtitle%%

StationTextReceived Event

Description

Notifies that Station Text has been received in the Station Text window.

Syntax

Private Sub object_StationTextReceived(sText)

The StationTextReceived Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
sText | A String value.


%%localitemtitle%%

TX Event

Description

Notifies that an outgoing Internet transmission has begun or ended.

Syntax

Private Sub object_TX(bTX)

The TX Event syntax has these parts:

Part | Description
object | An EchoLinkSession object.
bTX | A Boolean value.


%%localitemtitle%%

Enumerations Object

Members


%%localitemtitle%%

IStationEntries Collection
Description

IStationEntries Interface

Object Model

Members

Properties
_NewEnum | Read-only property | property _NewEnum
Count | Read-only property | Number of items in the list Returns a count of the number of collection members
Item | Read-only property | Retrieve the value of an item Returns the member of the collection identified by the Key parameter


%%localitemtitle%%

_NewEnum Property (IStationEntries)

Description

property _NewEnum

Property type

An Unknown object.

Syntax

object._NewEnum

The _NewEnum Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntries.


%%localitemtitle%%

Count Property (IStationEntries)

Description

Number of items in the list Returns a count of the number of collection members

Property type

A Long value.

Syntax

object.Count

The Count Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntries.


%%localitemtitle%%

Item Property (IStationEntries)

Description

Retrieve the value of an item Returns the member of the collection identified by the Key parameter

Property type

An IStationEntry object.

Syntax

object.Item(n)

The Item Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntries.
n | Required. A Long value.


%%localitemtitle%%

IStationEntry Object
Description

IStationEntry Interface

Members

Properties
Callsign | Read-only property | Callsign under which this station is logged in
LocalTime | Read-only property | Local time, as reported by station's own PC clock
Location | Read-only property | Location or description of node
NodeNumber | Read-only property | Node number (for DTMF access)
Status | Read-only property | Status (ON or BUSY)


%%localitemtitle%%

Callsign Property (IStationEntry)

Description

Callsign under which this station is logged in

Property type

A String value.

Syntax

object.Callsign

The Callsign Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntry.


%%localitemtitle%%

LocalTime Property

Description

Local time, as reported by station's own PC clock

Property type

A String value.

Syntax

object.LocalTime

The LocalTime Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntry.


%%localitemtitle%%

Location Property (IStationEntry)

Description

Location or description of node

Property type

A String value.

Syntax

object.Location

The Location Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntry.


%%localitemtitle%%

NodeNumber Property

Description

Node number (for DTMF access)

Property type

A Long value.

Syntax

object.NodeNumber

The NodeNumber Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntry.


%%localitemtitle%%

Status Property

Description

Status (ON or BUSY)

Property type

A String value.

Syntax

object.Status

The Status Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type IStationEntry.


%%localitemtitle%%

SetupConfig Object
Description

SetupConfig Class

Members

Methods
Apply method Apply

Properties
AlarmList | Read-write property | List of callsigns on which to sound an alarm
AudioForceFullDuplex | Read-write property | Open the sound card for play and record simultaneously
AudioHighPassFilter | Read-write property | Cut outgoing audio below 300 Hz
AudioInputDevice | Read-write property | Sound card for outgoing audio
AudioNetworkBuffers | Read-write property | Number of buffers to use for incoming packets
AudioOutputDevice | Read-write property | Sound card for incoming audio
AudioPCBuffers | Read-write property | Number of buffers to use for playback
AudioRecordingMode | Read-write property | Mode in which to record incoming audio
AudioSampleRateCompensate | Read-write property | Add or delete packets to compensate for sample-rate differences
AutoUpdate | Read-write property | Update the Station List automatically
Callsign | Read-write property | Callsign under which EchoLink is operating
Dialup | Read-write property | Dial the Internet connection at startup
DialupAutoDisconnect | Read-write property | Disconnect the dial-up connection on exit
DialupPhonebookEntry | Read-write property | Name of the phonebook entry to autodial
DoublingAlert | Read-write property | Display an alert message when doubling
Email | Read-write property | Operator's e-mail address
FavoritesList | Read-write property | List of callsigns in Favorites List
Location | Read-write property | Station location or description
LocationBusy | Read-write property | Location or description to show when busy
LocationFree | Read-write property | Location or description to show when NOT busy
MaxPeers | Read-write property | Maximum number of stations which can connect at the same time
Mode | Read-write property | Operating mode
Name | Read-write property | Operator's first name
Password | Read-write property | Login password
ReceiveHangTime | Read-write property | Time to remain in receive mode (ms) after last packet
SecurityAllowMultiConferencing | Read-write property | Allow this conference to connect with another conference
SecurityCallsignList | Read-write property | List of callsigns to accept or deny
SecurityCallsignsDeny | Read-write property | True to deny access to the listed callsigns, False to exclusively allow them
SecurityConferences | Read-write property | Allow connections with conferences
SecurityDynamicConferenceDetect | Read-write property | Disconnect a station if it becomes a conference
SecurityInbound | Read-write property | Apply security settings to inbound connect attempts
SecurityLinks | Read-write property | Allow connections with -L stations
SecurityOutbound | Read-write property | Apply security settings to outbound connect attempts
SecurityRepeaters | Read-write property | Allow connections with -R stations
SecurityUsers | Read-write property | Allow connections with single-user stations
Server | Read-write property | Hostname of addressing server (1 to 5)
ServerRetryTimeout | Read-write property | Time (secs) between login attempts
ShowConferenceStatus | Read-write property | Display the list of conferencees to all conferencees
ShowConnectedConference | Read-write property | ShowConnectedConference
SignalAlarm | Read-write property | Name of WAV file to play when an alarm is sounded
SignalConnected | Read-write property | Name of WAV file to play when a connection begins
SignalDisconnected | Read-write property | Name of WAV file to play when a connection ends
SignalOver | Read-write property | Name of WAV file to play when transmission ends
SignalTextMessage | Read-write property | Name of WAV file to play when Chat text is received
StationInformationFile | Read-write property | Name of text file to display to connectees
TimeoutConnectAttempt | Read-write property | Time to wait (secs) when trying to connect
TimeoutInactivity | Read-write property | Time to wait (secs) before disconnecting a dead connection
TimeoutReceiveLimit | Read-write property | Maximum duration (secs) for an inbound transmission
TimeoutTransmitLimit | Read-write property | Maximum duration (secs) for an outbound transmission
UpdateInQSO | Read-write property | Update the Station List automatically during a QSO
UpdateLocationWithConfName | Read-write property | Include name of connected conference in Location comment


%%localitemtitle%%

Apply Method (SetupConfig)

Description

method Apply

Return Type

None

Syntax

object.Apply bSave

The Apply Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
bSave | Required. A Boolean value.


%%localitemtitle%%

AlarmList Property

Description

List of callsigns on which to sound an alarm

Property type

An Object object.

Syntax

[Set] object.AlarmList [= Object]

The AlarmList Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
Object | An Object object.


%%localitemtitle%%

AudioForceFullDuplex Property

Description

Open the sound card for play and record simultaneously

Property type

A Boolean value.

Syntax

object.AudioForceFullDuplex [= value]

The AudioForceFullDuplex Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

AudioHighPassFilter Property

Description

Cut outgoing audio below 300 Hz

Property type

A Boolean value.

Syntax

object.AudioHighPassFilter [= value]

The AudioHighPassFilter Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

AudioInputDevice Property

Description

Sound card for outgoing audio

Property type

A String value.

Syntax

object.AudioInputDevice [= value]

The AudioInputDevice Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

AudioNetworkBuffers Property

Description

Number of buffers to use for incoming packets

Property type

An Integer value.

Syntax

object.AudioNetworkBuffers [= value]

The AudioNetworkBuffers Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

AudioOutputDevice Property

Description

Sound card for incoming audio

Property type

A String value.

Syntax

object.AudioOutputDevice [= value]

The AudioOutputDevice Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

AudioPCBuffers Property

Description

Number of buffers to use for playback

Property type

An Integer value.

Syntax

object.AudioPCBuffers [= value]

The AudioPCBuffers Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

AudioRecordingMode Property

Description

Mode in which to record incoming audio

Property type

An elRecordingMode enumeration.

Syntax

object.AudioRecordingMode [= value]

The AudioRecordingMode Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An elRecordingMode enumeration, as described in settings.

Settings

The settings for value are:

Constant | Value | Description
recNone | 0
recCallsign | 1
recQSO | 2


%%localitemtitle%%

AudioSampleRateCompensate Property

Description

Add or delete packets to compensate for sample-rate differences

Property type

A Boolean value.

Syntax

object.AudioSampleRateCompensate [= value]

The AudioSampleRateCompensate Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

AutoUpdate Property

Description

Update the Station List automatically

Property type

A Boolean value.

Syntax

object.AutoUpdate [= value]

The AutoUpdate Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

Callsign Property (SetupConfig)

Description

Callsign under which EchoLink is operating

Property type

A String value.

Syntax

object.Callsign [= value]

The Callsign Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

Dialup Property

Description

Dial the Internet connection at startup

Property type

A Boolean value.

Syntax

object.Dialup [= value]

The Dialup Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

DialupAutoDisconnect Property

Description

Disconnect the dial-up connection on exit

Property type

A Boolean value.

Syntax

object.DialupAutoDisconnect [= value]

The DialupAutoDisconnect Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

DialupPhonebookEntry Property

Description

Name of the phonebook entry to autodial

Property type

A String value.

Syntax

object.DialupPhonebookEntry [= value]

The DialupPhonebookEntry Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

DoublingAlert Property

Description

Display an alert message when doubling

Property type

A Boolean value.

Syntax

object.DoublingAlert [= value]

The DoublingAlert Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

Email Property

Description

Operator's e-mail address

Property type

A String value.

Syntax

object.Email [= value]

The Email Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

FavoritesList Property

Description

List of callsigns in Favorites List

Property type

An Object object.

Syntax

[Set] object.FavoritesList [= Object]

The FavoritesList Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
Object | An Object object.


%%localitemtitle%%

Location Property (SetupConfig)

Description

Station location or description

Property type

A String value.

Syntax

object.Location [= value]

The Location Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

LocationBusy Property

Description

Location or description to show when busy

Property type

A String value.

Syntax

object.LocationBusy [= value]

The LocationBusy Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

LocationFree Property

Description

Location or description to show when NOT busy

Property type

A String value.

Syntax

object.LocationFree [= value]

The LocationFree Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

MaxPeers Property

Description

Maximum number of stations which can connect at the same time

Property type

An Integer value.

Syntax

object.MaxPeers [= value]

The MaxPeers Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

Mode Property

Description

Operating mode

Property type

An elOperatingMode enumeration.

Syntax

object.Mode [= value]

The Mode Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An elOperatingMode enumeration, as described in settings.

Settings

The settings for value are:

Constant | Value | Description
opModeSingleUser | 0
opModeSysop | 1


%%localitemtitle%%

Name Property

Description

Operator's first name

Property type

A String value.

Syntax

object.Name [= value]

The Name Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

Password Property

Description

Login password

Property type

A String value.

Syntax

object.Password [= value]

The Password Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

ReceiveHangTime Property

Description

Time to remain in receive mode (ms) after last packet

Property type

An Integer value.

Syntax

object.ReceiveHangTime [= value]

The ReceiveHangTime Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

SecurityAllowMultiConferencing Property

Description

Allow this conference to connect with another conference

Property type

A Boolean value.

Syntax

object.SecurityAllowMultiConferencing [= value]

The SecurityAllowMultiConferencing Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityCallsignList Property

Description

List of callsigns to accept or deny

Property type

An Object object.

Syntax

[Set] object.SecurityCallsignList [= Object]

The SecurityCallsignList Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
Object | An Object object.


%%localitemtitle%%

SecurityCallsignsDeny Property

Description

True to deny access to the listed callsigns, False to exclusively allow them

Property type

A Boolean value.

Syntax

object.SecurityCallsignsDeny [= value]

The SecurityCallsignsDeny Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityConferences Property

Description

Allow connections with conferences

Property type

A Boolean value.

Syntax

object.SecurityConferences [= value]

The SecurityConferences Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityDynamicConferenceDetect Property

Description

Disconnect a station if it becomes a conference

Property type

A Boolean value.

Syntax

object.SecurityDynamicConferenceDetect [= value]

The SecurityDynamicConferenceDetect Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityInbound Property

Description

Apply security settings to inbound connect attempts

Property type

A Boolean value.

Syntax

object.SecurityInbound [= value]

The SecurityInbound Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityLinks Property

Description

Allow connections with -L stations

Property type

A Boolean value.

Syntax

object.SecurityLinks [= value]

The SecurityLinks Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityOutbound Property

Description

Apply security settings to outbound connect attempts

Property type

A Boolean value.

Syntax

object.SecurityOutbound [= value]

The SecurityOutbound Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityRepeaters Property

Description

Allow connections with -R stations

Property type

A Boolean value.

Syntax

object.SecurityRepeaters [= value]

The SecurityRepeaters Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SecurityUsers Property

Description

Allow connections with single-user stations

Property type

A Boolean value.

Syntax

object.SecurityUsers [= value]

The SecurityUsers Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

Server Property

Description

Hostname of addressing server (1 to 5)

Property type

A String value.

Syntax

object.Server(nIndex) [= value]

The Server Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
nIndex | Required. An Integer value.
value | A String value.


%%localitemtitle%%

ServerRetryTimeout Property

Description

Time (secs) between login attempts

Property type

An Integer value.

Syntax

object.ServerRetryTimeout [= value]

The ServerRetryTimeout Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

ShowConferenceStatus Property

Description

Display the list of conferencees to all conferencees

Property type

A Boolean value.

Syntax

object.ShowConferenceStatus [= value]

The ShowConferenceStatus Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

ShowConnectedConference Property

Description

ShowConnectedConference

Property type

A Boolean value.

Syntax

object.ShowConnectedConference [= value]

The ShowConnectedConference Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SignalAlarm Property

Description

Name of WAV file to play when an alarm is sounded

Property type

A String value.

Syntax

object.SignalAlarm [= value]

The SignalAlarm Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

SignalConnected Property

Description

Name of WAV file to play when a connection begins

Property type

A String value.

Syntax

object.SignalConnected [= value]

The SignalConnected Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

SignalDisconnected Property

Description

Name of WAV file to play when a connection ends

Property type

A String value.

Syntax

object.SignalDisconnected [= value]

The SignalDisconnected Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

SignalOver Property

Description

Name of WAV file to play when transmission ends

Property type

A String value.

Syntax

object.SignalOver [= value]

The SignalOver Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

SignalTextMessage Property

Description

Name of WAV file to play when Chat text is received

Property type

A String value.

Syntax

object.SignalTextMessage [= value]

The SignalTextMessage Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

StationInformationFile Property

Description

Name of text file to display to connectees

Property type

A String value.

Syntax

object.StationInformationFile [= value]

The StationInformationFile Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A String value.


%%localitemtitle%%

TimeoutConnectAttempt Property

Description

Time to wait (secs) when trying to connect

Property type

An Integer value.

Syntax

object.TimeoutConnectAttempt [= value]

The TimeoutConnectAttempt Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

TimeoutInactivity Property

Description

Time to wait (secs) before disconnecting a dead connection

Property type

An Integer value.

Syntax

object.TimeoutInactivity [= value]

The TimeoutInactivity Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

TimeoutReceiveLimit Property

Description

Maximum duration (secs) for an inbound transmission

Property type

An Integer value.

Syntax

object.TimeoutReceiveLimit [= value]

The TimeoutReceiveLimit Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

TimeoutTransmitLimit Property

Description

Maximum duration (secs) for an outbound transmission

Property type

An Integer value.

Syntax

object.TimeoutTransmitLimit [= value]

The TimeoutTransmitLimit Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | An Integer value.


%%localitemtitle%%

UpdateInQSO Property

Description

Update the Station List automatically during a QSO

Property type

A Boolean value.

Syntax

object.UpdateInQSO [= value]

The UpdateInQSO Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

UpdateLocationWithConfName Property

Description

Include name of connected conference in Location comment

Property type

A Boolean value.

Syntax

object.UpdateLocationWithConfName [= value]

The UpdateLocationWithConfName Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SetupConfig.
value | A Boolean value.


%%localitemtitle%%

SysopConfig Object
Description

SysopConfig Class

Members

Methods
Apply Apply changes and reset system

Properties
DTMFCommands | Read-only property | List of DTMF sequences for different EchoLink functions
DTMFDecoder | Read-write property | Type of DTMF decoding to use (internal, external, or none)
DTMFDisableOnPTT | Read-write property | True to disable the DTMF decoder when the local transmitter is key-down
DTMFFineTuning | Read-write property | Frequency adjustment (in percent) for internal DTMF decoder
DTMFInterdigit | Read-write property | Minimum time (in ms) to require between valid DTMF digits
DTMFLogging | Read-write property | True to log all detected DTMF digits to System Log file
DTMFMute | Read-write property | True to mute detected DTMF signals in the audio signal to remote stations
DTMFRemotePad | Read-write property | True to enable the EchoLink DTMF encoder pad for remote stations when they connect
DTMFShortcuts | Read-only property | List of DTMF sequences for connecting to specific stations
DTMFSN | Read-write property | Acceptable signal-to-noise ratio (in dB) for DTMF decoder (internal DTMF only)
DTMFTolerance | Read-write property | Frequency tolerance (in percent) for DTMF tone detector (internal DTMF only)
DTMFTwist | Read-write property | Acceptable power difference (in dB) between high and low DTMF tones (internal DTMF only)
PTTActivation | Read-write property | Method EchoLink uses to key the local transmitter
PTTPassThrough | Read-write property | True if PTT should be keyed when space bar is pressed
RXAntiThump | Read-write property | Delay (after key-up) during which VOX or COS will not trigger, in milleseconds
RXCarrierDetect | Read-write property | Method of detecting an incoming RF signal
RXCOMPort | Read-write property | COM port number (1-8) to use for COS detection
RXInvert | Read-write property | True to detect COS when voltage is low, False to detect COS when voltage is high
RXVOXAntiTripMute | Read-write property | property RXVOXAntiTripMute
RXVOXAntiTripTiming | Read-write property | Time constant for noise bursts to be ignored by VOX
RXVOXDelay | Read-write property | Time to remain in TX after VOX (or COS) releases
RXVOXNotchFreq | Read-write property | Frequency at which VOX will ignore incoming signals
RXVOXThreshold | Read-write property | Audio level at which VOX is triggered, in percent
ToneBurstDuration | Read-write property | Duration (in ms) of tone-burst signal
ToneBurstFrequency | Read-write property | Frequency (in Hz) of tone-burst signal
ToneBurstMode | Read-write property | Method by which tone burst is sent to local transmitter
TXCOM9600 | Read-write property | True if serial interface runs at 9600 bps, otherwise False
TXCOMPort | Read-write property | COM port number (1-8) to use for PTT control


%%localitemtitle%%

Apply Method (SysopConfig)

Description

Apply changes and reset system

Return Type

None

Syntax

object.Apply bSave

The Apply Method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
bSave | Required. A Boolean value.


%%localitemtitle%%

DTMFCommands Property

Description

List of DTMF sequences for different EchoLink functions

Property type

An Object object.

Syntax

object.DTMFCommands

The DTMFCommands Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.


%%localitemtitle%%

DTMFDecoder Property

Description

Type of DTMF decoding to use (internal, external, or none)

Property type

An elDTMFSource enumeration.

Syntax

object.DTMFDecoder [= value]

The DTMFDecoder Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An elDTMFSource enumeration, as described in settings.

Settings

The settings for value are:

Constant | Value | Description
dtmfExternal | 0
dtmfInternal | 1
dtmfDisabled | 2


%%localitemtitle%%

DTMFDisableOnPTT Property

Description

True to disable the DTMF decoder when the local transmitter is key-down

Property type

A Boolean value.

Syntax

object.DTMFDisableOnPTT [= value]

The DTMFDisableOnPTT Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

DTMFFineTuning Property

Description

Frequency adjustment (in percent) for internal DTMF decoder

Property type

A Single value.

Syntax

object.DTMFFineTuning [= value]

The DTMFFineTuning Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Single value.


%%localitemtitle%%

DTMFInterdigit Property

Description

Minimum time (in ms) to require between valid DTMF digits

Property type

An Integer value.

Syntax

object.DTMFInterdigit [= value]

The DTMFInterdigit Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

DTMFLogging Property

Description

True to log all detected DTMF digits to System Log file

Property type

A Boolean value.

Syntax

object.DTMFLogging [= value]

The DTMFLogging Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

DTMFMute Property

Description

True to mute detected DTMF signals in the audio signal to remote stations

Property type

A Boolean value.

Syntax

object.DTMFMute [= value]

The DTMFMute Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

DTMFRemotePad Property

Description

True to enable the EchoLink DTMF encoder pad for remote stations when they connect

Property type

A Boolean value.

Syntax

object.DTMFRemotePad [= value]

The DTMFRemotePad Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

DTMFShortcuts Property

Description

List of DTMF sequences for connecting to specific stations

Property type

An Object object.

Syntax

object.DTMFShortcuts

The DTMFShortcuts Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.


%%localitemtitle%%

DTMFSN Property

Description

Acceptable signal-to-noise ratio (in dB) for DTMF decoder (internal DTMF only)

Property type

A Single value.

Syntax

object.DTMFSN [= value]

The DTMFSN Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Single value.


%%localitemtitle%%

DTMFTolerance Property

Description

Frequency tolerance (in percent) for DTMF tone detector (internal DTMF only)

Property type

A Single value.

Syntax

object.DTMFTolerance [= value]

The DTMFTolerance Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Single value.


%%localitemtitle%%

DTMFTwist Property

Description

Acceptable power difference (in dB) between high and low DTMF tones (internal DTMF only)

Property type

A Single value.

Syntax

object.DTMFTwist [= value]

The DTMFTwist Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Single value.


%%localitemtitle%%

PTTActivation Property

Description

Method EchoLink uses to key the local transmitter

Property type

An elTXControl enumeration.

Syntax

object.PTTActivation [= value]

The PTTActivation Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An elTXControl enumeration, as described in settings.

Settings

The settings for value are:

Constant | Value | Description
txVOX | 0
txASCII | 1
txRTS | 2
txDSR | 3


%%localitemtitle%%

PTTPassThrough Property

Description

True if PTT should be keyed when space bar is pressed

Property type

A Boolean value.

Syntax

object.PTTPassThrough [= value]

The PTTPassThrough Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

RXAntiThump Property

Description

Delay (after key-up) during which VOX or COS will not trigger, in milleseconds

Property type

An Integer value.

Syntax

object.RXAntiThump [= value]

The RXAntiThump Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

RXCarrierDetect Property

Description

Method of detecting an incoming RF signal

Property type

An elCarrierDetect enumeration.

Syntax

object.RXCarrierDetect [= value]

The RXCarrierDetect Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An elCarrierDetect enumeration, as described in settings.

Settings

The settings for value are:

Constant | Value | Description
cdManual | 0
cdVOX | 1
cdCD | 2
cdCTS | 3
cdDSR | 4


%%localitemtitle%%

RXCOMPort Property

Description

COM port number (1-8) to use for COS detection

Property type

An Integer value.

Syntax

object.RXCOMPort [= value]

The RXCOMPort Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

RXInvert Property

Description

True to detect COS when voltage is low, False to detect COS when voltage is high

Property type

A Boolean value.

Syntax

object.RXInvert [= value]

The RXInvert Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

RXVOXAntiTripMute Property

Description

property RXVOXAntiTripMute

Property type

A Boolean value.

Syntax

object.RXVOXAntiTripMute [= value]

The RXVOXAntiTripMute Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

RXVOXAntiTripTiming Property

Description

Time constant for noise bursts to be ignored by VOX

Property type

An Integer value.

Syntax

object.RXVOXAntiTripTiming [= value]

The RXVOXAntiTripTiming Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

RXVOXDelay Property

Description

Time to remain in TX after VOX (or COS) releases

Property type

An Integer value.

Syntax

object.RXVOXDelay [= value]

The RXVOXDelay Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

RXVOXNotchFreq Property

Description

Frequency at which VOX will ignore incoming signals

Property type

An Integer value.

Syntax

object.RXVOXNotchFreq [= value]

The RXVOXNotchFreq Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

RXVOXThreshold Property

Description

Audio level at which VOX is triggered, in percent

Property type

An Integer value.

Syntax

object.RXVOXThreshold [= value]

The RXVOXThreshold Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

ToneBurstDuration Property

Description

Duration (in ms) of tone-burst signal

Property type

An Integer value.

Syntax

object.ToneBurstDuration [= value]

The ToneBurstDuration Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

ToneBurstFrequency Property

Description

Frequency (in Hz) of tone-burst signal

Property type

An Integer value.

Syntax

object.ToneBurstFrequency [= value]

The ToneBurstFrequency Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

ToneBurstMode Property

Description

Method by which tone burst is sent to local transmitter

Property type

An elToneBurstMode enumeration.

Syntax

object.ToneBurstMode [= value]

The ToneBurstMode Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An elToneBurstMode enumeration, as described in settings.

Settings

The settings for value are:

Constant | Value | Description
tbNone | 0
tbOnConnect | 1
tbOnTX | 2


%%localitemtitle%%

TXCOM9600 Property

Description

True if serial interface runs at 9600 bps, otherwise False

Property type

A Boolean value.

Syntax

object.TXCOM9600 [= value]

The TXCOM9600 Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | A Boolean value.


%%localitemtitle%%

TXCOMPort Property

Description

COM port number (1-8) to use for PTT control

Property type

An Integer value.

Syntax

object.TXCOMPort [= value]

The TXCOMPort Property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type SysopConfig.
value | An Integer value.


%%localitemtitle%%

elCarrierDetect Enumeration

Members

Constant | Value | Description
cdManual | 0
cdVOX | 1
cdCD | 2
cdCTS | 3
cdDSR | 4


%%localitemtitle%%

elDTMFSource Enumeration

Members

Constant | Value | Description
dtmfExternal | 0
dtmfInternal | 1
dtmfDisabled | 2


%%localitemtitle%%

elIDType Enumeration

Members

Constant | Value | Description
idDefault | 0
idMorse | 1
idSpoken | 2
idWave | 3


%%localitemtitle%%

elOperatingMode Enumeration

Members

Constant | Value | Description
opModeSingleUser | 0
opModeSysop | 1


%%localitemtitle%%

elRecordingMode Enumeration

Members

Constant | Value | Description
recNone | 0
recCallsign | 1
recQSO | 2


%%localitemtitle%%

elToneBurstMode Enumeration

Members

Constant | Value | Description
tbNone | 0
tbOnConnect | 1
tbOnTX | 2


%%localitemtitle%%

elTXControl Enumeration

Members

Constant | Value | Description
txVOX | 0
txASCII | 1
txRTS | 2
txDSR | 3


%%projectgrouptitle%%

EchoLink Programmer's Reference

Description

EchoLink Object Library ver 1.7

Object Model


%%phrase%%

References

References

FileName Version Size Description